Google News Don’t show keywords field

Forums XML Sitemap & Google News Google News Advanced Google News Don’t show keywords field

Viewing 14 reply threads
  • Author
    • #33654


      I installed the plugin, but the keyword field doesn’t appear on the post creation screen. How do I get it to appear?

      I’ve already enabled the field in the plugin’s settings. Interestingly, the selection box only shows keywords. It does not display the categories to be selected.

      Thank you for your help.

    • #33677

      Hi, are you using a custom post type or pages for your news posts by any chance? In that case the option will only show “Keywords” because the other taxonomies (Tags and Categories) are not available in all selected post types.

      But a “Keywords” section should appear on the right side of the edit screen, normally below the “Permalink” section…

      If not, please let me know which custom post type (or plugin) you are using for your news posts.

    • #33683

      Hi, Rolf.

      Thanks for the feedback. I use the default post in my WordPress (no change). My theme is Astra Pro.

      I’m putting a print (attachment) of my screen with the sections that appear on the right (the keyword section is not shown).


      You must be logged in to view attached files.
    • #33697

      Strange indeed. I wonder if it is the Astra Pro theme… I’ll try to test with he free Astra theme first and will let you know.

      Are you using any plugins that manage custom post types or custom fields like AFC or Custom Post Type UI?

    • #33699

      Quick update: I tested the free Astra theme but was not able to reproduce the issue. So it might be the Pro version, or another plugin.

      To make sure it is not a lingering old setting, please go to Settings > Google News and re-save the options on the General tab. Then check the Advanced tab again.

    • #33704


      I have identified what is causing the problem.

      When I check the Story option (Settings > Google News, General Tab) the problem occurs (I have stories published too).

      When I uncheck the Story option, the keywords field appears in the posts.


      You must be logged in to view attached files.
    • #33707

      Complementing the previous message.

      On the Stories creation page, the keywords field is appearing when the “Story” option is checked.

      I use the Google’s plugin for stories.

    • #33716

      Ok, right. So the Story post type is a custom post type. This would explain “Keywords” being the only available option for Keywords, not Categories or Tags. But it does not explain the issue that Keywords tab does not appear on the post edit screen.

      Are you saying the Keywords section appears on the Story edit screen but not on Posts?

      Are you using for these stories?

    • #33718

      Yes, Rolf. The Keywords section appears in the story editing screen, but not in posts (screenshot attached). It only appears in the story editing screen if I uncheck the “Story” option in General Tab.

      And yes too. I am using the plugin for my stories.

      You must be logged in to view attached files.
    • #33721

      Update: I was able to reproduce the issue with Web Stories. We’ll work on a fix and I’ll let you know ASAP 🙂

    • #33724

      Perfect, Rolf!


    • #33727

      OK, there is a new beta version available now that should fix the issue. To get the beta release, follow these steps:

      1. Go to Settings > Google News and then open the License tab, you should see the option “Get updates for pre-release versions of Google News Advanced.”
      2. Activate that option and then Save Changes.
      3. Go to Dashboard > Updates and see if the new version 1.3.2-beta-4 is available there. You may need to click “Check again.”
      4. Update to the new beta-4 version.

      Please let me know 🙂

      PS: after updating to the beta version and everything is working okay, you can disable the pre-release option on the License tab again. The beta version will remain installed but will get updated once the new stable version is released.

    • #33729

      You should also be able to simply download the beta-4 version from then use the zip to install as a new plugin (which will upgrade the installed version)

    • #33740

      Hi, Rolf.

      Now, the Keywords section appears in the post edit screen too.

      Thank you for the help.

    • #33742

      Thank you for your feedback! The fix will make it into the next release 🙂

Viewing 14 reply threads
  • You must be logged in to reply to this topic.