WPBakery grids and Easy FancyBox Pro

Forums Easy FancyBox Pro WPBakery grids and Easy FancyBox Pro

Tagged: 

  • This topic has 1 reply, 2 voices, and was last updated 1 month ago by Rolf.
Viewing 1 reply thread
  • Author
    Posts
    • #22493
      Johannes Tümmers
      Participant

      Hello dear folks,

      I’m working on a new WP-site with up-to-date plugins, WP 5.4.2, WPBakery 6.2.0, and now Easy FancyBox Pro 1.8.1

      I just couldn’t get Fancybox go work with the different grids of WPBakery, even though I checked the checkbox ‘Compatible with WPBakery / Visual Composer – Masonry Grid Gallery’.

      Until I tracked down the PHP source codes of this file:

      /wp-content/plugins/js_composer/include/templates/shortcodes/vc_gitem_zone.php.
      In there, lines 62 to 83 build the link for the given elements. I added ‘fancybox’ to the code where the CSS-classes are built. Like:

      Before: class="vc_gitem-link vc-zone-link"
      After: class="vc_gitem-link vc-zone-link fancybox"

      Now, Fancybox works for me, so far at least. But I had hoped, the Pro version would solve this for me with the above mentioned checkbox.
      Maybe this helps?

      Many thanks and greetings to you who made this really nice plugin!
      It might well be that I did something wrong of overlooked some options etc. and there’s a much easier solution for this. In that case, please give me a hint or something, because this solution of mine is, sadly, not very update-safe, hehehe.

      Stay well and sound!
      Cheers,
      Johannes

    • #30007
      Rolf
      Keymaster

      Hi Johannes, thanks for sending the zip. I’ve sent an email to you after testing with different gallery blocks but in all cases the fancybox light box seems to work wihtout any modifications… I’ll need more info to be able to reproduce the issue so I hope you can tell me more via email 🙂

Viewing 1 reply thread
  • You must be logged in to reply to this topic.