Fatal error to install XML Sitemap plugin

Forums XML Sitemap & Google News XML Sitemap Fatal error to install XML Sitemap plugin

Tagged: 

Viewing 21 reply threads
  • Author
    Posts
    • #17673
      Eduardo Trejo
      Participant

      I sent a ticket to support and I have no answer.
      How do I get help with a problem activating the plugin?

      Attachments:
      You must be logged in to view attached files.
    • #17676
      Pharéo
      Keymaster

      Hi Eduardo, I responded to your email about half an hour ago. Maybe it landed in the spam folder?

      My question is: where does the error occur? On a post sitemap? In your mail there was a screen shot of memory errors, so it might help to set the “Split by” option to “Month” on Settings > XML Sitemap…

    • #17680
      Pharéo
      Keymaster

      From this topic title I understand that the error occurs during plugin installation. Is that the case? Is that the Google News Advanced extension plugin or the main XML Sitemap & Google News plugin? And is that when installing or when activating?

    • #17681
      Eduardo Trejo
      Participant

      Thanks Pharéo.
      Google News Advanced works fine. The XML Sitemap, works in Split By: “None”, but I have more than 12 thousand articles, of 5 years. List them all at once.

      When changing to Year or Month is when it causes problems. It does not group the links by year or month. You have consumed all the resources of the web server.
      I reinstalled the add-ons, purged the permanent links, emptied all the caches.

      I had to uninstall Google News Advanced extension and XML Sitemap & Google News plugin.

      In another place where I installed a second license, everything works normally.
      Thank you

      Note: Attached image of what happened in the WordPress admin, that warning had not seen before. Only yesterday that I activated XML Sitemap & Google News plugin and News Advanced

      Attachments:
      You must be logged in to view attached files.
    • #17689
      Pharéo
      Keymaster

      When changing to Year or Month is when it causes problems. It does not group the links by year or month. You have consumed all the resources of the web server.

      That is very strange… Is there any chance I can take a look on the admin side? If you create a temporary admin account and send me the details via https://premium.status301.com/contact/ ?

      Or do you see any related errors in the server error log?

    • #17693
      Eduardo Trejo
      Participant

      The problem was solved. What happened is that I activated XML Sitemap and Google News Advanced at the same time, surely that caused a conflict; I have 12 thousand items.
      Thanks for the support.

    • #17741
      Pharéo
      Keymaster

      So you have only the XML Sitemap & Google News plugin activated now? And can you switch to Month or Year or does that still cause a problem?

    • #17742
      Eduardo Trejo
      Participant

      Both are already activated (XML Sitemap and Advanced).

      I can already select by month and year.
      Now I want to know how to have only 1000 articles per sitemap.

      I am using “year” but I have up to 4 thousand articles per year. Is it possible to have a thousand items for each sitemap?

      Thank you

    • #17746
      Pharéo
      Keymaster

      If you set “Split by: Month” you will have less posts per sitemap. On option to split by “Number” is planned for a future version but not ready yet…

    • #17747
      Eduardo Trejo
      Participant

      It doesn’t affect me, but it seems that Google doesn’t think the same.
      I will wait for that update.
      Thank you

    • #17769
      Eduardo Trejo
      Participant

      Hi.
      Sorry to reopen this conversation, but I didn’t realize that Serch Console detects errors in Posttype * year sitemap.

      Any ideas to solve this?
      Thank you

      Attachments:
      You must be logged in to view attached files.
    • #17784
      Pharéo
      Keymaster

      Hi Eduardo, I’ve entered both your sitemap.xml and your sitemap-posttype-post.2019.xml in the online validator tool https://www.xml-sitemaps.com/validate-xml-sitemap.html and both are valid.

      Maybe the error is an old one and will disappear after a while. Or you can try removing the sitemap from your Search Console and then submit it again. Hopefully the spider will re-validate it then.

    • #17785
      Pharéo
      Keymaster

      Or… you can set the option Split by to Month which will make the sitemaps smaller and faster to index. 🙂

    • #17832
      Eduardo Trejo
      Participant

      Hi guys

      I want to inform you that I continue with the problems in the sitemap, Search Console does not recognize the Post Sitemap.
      I also tested with the sitemap validator, and it is correct, but Search Console does not detect it, and I really need the sitemap to be read by Google.
      The sitemap of the pages and categories are correct, they are read without problems, but the sitemap of the content does not recognize it.
      Thank you

      Attachments:
      You must be logged in to view attached files.
    • #17834
      Pharéo
      Keymaster

      Hi Eduardo, I checked your yearly post sitemaps a few times. They are really slow and I even saw the 5OO internal server error once.

      Make sure you keep your option ‘Split by’ on ‘Month’. Your monthly sitemaps load fast enough and all are correct.

      However, even though the response is correct, the status code that is returned by the server is 4O4 which means “not found”. I suspect Google sees this as a problem (and it is!) so it will not treat the sitemaps further.

      Do you have any idea why your server or WordPress itself would return a 404 status code for posts or feeds?

    • #17835
      Eduardo Trejo
      Participant

      I have no idea
      Before I used Google XML Sitemap, free version, and it worked correctly.

      Attachments:
      You must be logged in to view attached files.
    • #17837
      Eduardo Trejo
      Participant

      This is the Google XML Sitemap configuration

      Attachments:
      You must be logged in to view attached files.
    • #17843
      Pharéo
      Keymaster

      It all looks correct. Only the response status 404 is wrong. I’ve only seen this happen on older WordPress versions without any posts published but that is certainly not the case here.

      I wonder if it’s a conflict with another plugin.

      Any chance you could create a temporary admin account so I can take a look on the back end? You can send me the details via the contact form or a private message (link “send a message” under my icon on the left here).

    • #17844
      Pharéo
      Keymaster

      Or, if you are not afraid of modifying PHP files, you can try this:

      1. Go to Plugins > Plugin Editor and select XML Sitemap & Google News on the top right.
      2. Open >models in files list on the right en choose the file functions.public-shared.php
      3. There you will see the first function:

      
      function xmlsf_headers( $headers ) {
      	// set noindex
      	$headers['X-Robots-Tag'] = 'noindex, follow';
      	$headers['Content-Type'] = 'text/xml; charset=' . get_bloginfo('charset');
      	return $headers;
      }
      

      Now add a new line right after function xmlsf_headers( $headers ) { and enter $headers['Status'] = '200'; there. It should look like:

      
      function xmlsf_headers( $headers ) {
      	$headers['Status'] = '200';
      	// set noindex
      	$headers['X-Robots-Tag'] = 'noindex, follow';
      	$headers['Content-Type'] = 'text/xml; charset=' . get_bloginfo('charset');
      	return $headers;
      }
      

      Then click the button Update File at the bottom.

      Let me know and I’ll check the response status of your sitemaps again 🙂

    • #17872
      Eduardo Trejo
      Participant

      The bug has been fixed!
      I apologize for not answering immediately.
      It works, I hope it continues.
      Thank you for helping

      Attachments:
      You must be logged in to view attached files.
    • #17879
      RavanH
      Keymaster

      Hi Eduardo, thanks for confirming!

      Apparently, forcing the Status response to 200 is enough. I’ll work that into the next release so you won’t need to do this edit again after updating the plugin.

      If you ever find out why this 404 response occurs or where it is coming from, we’d really like to know 🙂

    • #17880
      Eduardo Trejo
      Participant

      Sure!
      Thanks a lot.

Viewing 21 reply threads
  • You must be logged in to reply to this topic.